Module: xenomai-jki
Branch: for-upstream
Commit: 4656bb491e67c7464d28d34b5bffb5ed70f42127
URL:    
http://git.xenomai.org/?p=xenomai-jki.git;a=commit;h=4656bb491e67c7464d28d34b5bffb5ed70f42127

Author: Jan Kiszka <jan.kis...@siemens.com>
Date:   Tue Feb 12 10:21:25 2013 +0100

x86: Disarm WP_WORKS_OK check for kernels >= 3.8

i386 was buried, thus this flag is implicitly set now.

Signed-off-by: Jan Kiszka <jan.kis...@siemens.com>

---

 include/asm-x86/hal_32.h |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/include/asm-x86/hal_32.h b/include/asm-x86/hal_32.h
index 4251fa0..9feb3f0 100644
--- a/include/asm-x86/hal_32.h
+++ b/include/asm-x86/hal_32.h
@@ -57,7 +57,8 @@
 
 #include <asm-generic/xenomai/hal.h>   /* Read the generic bits. */
 
-#ifndef CONFIG_X86_WP_WORKS_OK
+#if !defined(CONFIG_X86_WP_WORKS_OK) && \
+    LINUX_VERSION_CODE < KERNEL_VERSION(3,8,0)
 #error "Xenomai has to rely on the WP bit, CONFIG_M486 or better required"
 #endif /* CONFIG_X86_WP_WORKS_OK */
 


_______________________________________________
Xenomai-git mailing list
Xenomai-git@xenomai.org
http://www.xenomai.org/mailman/listinfo/xenomai-git

Reply via email to