On 09/20/2016 08:37 AM, Leopold Palomo-Avellaneda wrote:
> El Dimarts, 20 de setembre de 2016, a les 06:18:45, 
> dietmar.schind...@manroland-web.com va escriure:
>>> Von: Xenomai [mailto:xenomai-boun...@xenomai.org] Im Auftrag von Leopold
>>> Palomo-Avellaneda Gesendet: Montag, 19. September 2016 22:45
>>>
>>> I'm trying to build a shared library, using the posix skin with Xenomai
>>> 3.0.3. I have built xenomai with:
>>>
>>> '--with-core=cobalt' '--enable-smp' '--enable-pshared' '--enable-fortify'
>>> '--enable-shared
>>>
>>> I built withour any error. However, when I try to build a library (shared)
>>> that uses xenomai I got this error:
>>>
>>> /usr/bin/ld: /usr/xenomai/lib/xenomai/bootstrap.o: relocation R_X86_64_32
>>> against `.rodata.str1.1' can not be used when making a shared object;
>>> recompile with -fPIC
>>
>> Here is an answer to a similar problem:
>> http://stackoverflow.com/a/38431538/2413201 It says to use the compiler
>> flags -Wformat=0 or/and -Wno-format-security; perhaps it helps also in your
>> case. --
> 
> Thanks,
> 
> but not. I have tried in both cases: recompiling my lib and xenomai. Still 
> getting the same error.
> 
> What surprises me more is that with 2.6.x I have no error but with 3.x I get 
> it. 
> 

2.6.x did not have any bootstrap module, which explains the difference.

-- 
Philippe.

_______________________________________________
Xenomai mailing list
Xenomai@xenomai.org
https://xenomai.org/mailman/listinfo/xenomai

Reply via email to