Thanks.

I' ve red about RPI as reference board, does rtnet works on them ? which boards/model should I give a try ?


Alessio


On 16/02/2018 17:41, Greg Gallagher wrote:
     As far as I know there is no Ipipe patch for L4T so you'd have to
use mainline Linux if you'd like to run Xenomai on the TX1 or TX2.
I'm not sure what tools this would leave you with for the GPU but I
don't think Cuda works with the nouveau drivers.
     The other issue that I've seen on x86 boards with Nvidia gpus is
it's unknown how long the Nvidia driver turn interrupts off for, so
latency may be affected.  I don't think there are plans to port the
ipipe to L4T but if you would like to try I'm sure people here would
be willing to answer questions.

-Greg

On Fri, Feb 16, 2018 at 10:10 AM, alessio margan <alessio.mar...@iit.it> wrote:
Hi all,

does anybody have successfully run Xenomai-3+RTnet on NVIDIA Jetson TX1/TX2
compute modules ?

this is a TX1 lscpu output

nvidia@tegra-ubuntu:~$ lscpu

Architecture:          aarch64
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
Model name:            ARMv8 Processor rev 1 (v8l)
CPU max MHz:           1734.0000
CPU min MHz:           102.0000
Hypervisor vendor:     (null)
Virtualization type:   full
L1d cache:             32K
L1i cache:             48K
L2 cache:              2048K


_______________________________________________
Xenomai mailing list
Xenomai@xenomai.org
https://xenomai.org/mailman/listinfo/xenomai

Reply via email to