You said:
I just built from CVS on my Radeon 7500 Mobility laptop.
Starting X yields a blank display and a locked keyboard.  Attempting to 
X or shutdown the laptop via ssh results in a complete system lockup.

I had a similar problem (same video card, binary) that was 
caused by a mismatched radeon.o kernel module.  I'm not sure if that's 
what's going wrong for you though.  Building the module from the latest 
DRI CVS sources solved it, but there were other problems:

1.  The new cursors don't work well with hardware cursor acceleration in 
the radeon driver.  X would lock for a second or two any time the 
cursor had to change from a new-style Xcursor cursor (e.g. red arrow) 
to an old core cursor (e.g. edge resize arrows).  Using option 
"SWcursor" "true" solves the problem at the expense of disabling hw 
cursor acceleration.

2.  I was using KDM and after exiting X my machine would lock up as it 
tried to restart the login screen.  I think that even without KDM I 
couldn't restart X after I started it once.  I'm not positive about 
this though.

Out of curiosity, since you also have a 7500 mobility, have you ever 
tried running it dual-head with an external monitor?  I'm trying to 
make that happen and having problems:


>>>-- Nathaniel Gray -- Caltech Computer Science ------>
>>>-- Mojave Project -- -->

XFree86 mailing list

Reply via email to