I have a mixed setup with DOVECAT for IMAP access, and XMAIl 1.27 for the rest. 
 The relay is cosed until authentication is made In order to have a centralized 
place for authentication I used in XMAIL external authentication.  However 
seems it is not working as I receive 550 Relay Denied when I try to send an 
email using this XMAIL server.
The setup is as following:
In smtpextauth.tab I put following line:
"LOGIN" "/config/scripts/checkSmtpAuth.sh" "@@AUTH" "@@USER" "@@PASS" "@@RFILE"
In server tab I have:"DefaultSmtpPerms" "MRVZ"

In checkSmtpAuth.sh I always exit with 0 for testing.  However I received 550 
Relay denied each time I tried to send an email.  If the script exits with 1 
then the error is different, (Authentication error). 

I tried also populating RFILE with Perms=MR but without success. I tried also 
with Perms=MRVZ . No change.
Also another issue is the fact that those RFILE files were never get deleted.  
For each email, that file is created and stays there forever (need external 
action to delete it)
Is there any other settings that need to be made or is this a bug ?
Using internal authentication (smtpauth.tab or mailuser.tab) emptying 
smtpextauth.tab  there is no such error, and everything works as expected.
Unfortunately there is no debug log in application, so only way to figure out 
is DEBUG, and currently it is installed on an embedded router so no way to 
xmail mailing list

Reply via email to