Hello.

libtool: compile:  /opt/sunstudio12.1/bin/cc -DHAVE_CONFIG_H -I. -I..
-I./include -I../include -D_REENTRANT -I/opt/local/zlib//include -g -c
../relaxng.c  -KPIC -DPIC -o .libs/relaxng.o
"../relaxng.c", line 5372: operands have incompatible types:
         pointer to char ":" pointer to const unsigned char
"../relaxng.c", line 5372: warning: argument #5 is incompatible with prototype:
        prototype: pointer to const unsigned char : "../relaxng.c", line 510
        argument : pointer to char
"../relaxng.c", line 9462: warning: argument #3 is incompatible with prototype:
        prototype: pointer to const unsigned char : "../relaxng.c", line 2347
        argument : pointer to char
cc: acomp failed for ../relaxng.c
*** Error code 1
make: Fatal error: Command failed for target `relaxng.lo'
Current working directory /export/home/user/Source/libxml2-2.7.6/.32.

(Also available at http://pastebin.ca/1674937 for a guaranteed
unwrapped version...)

I was trying to compile libxml2-2.7.6 on a Solaris 10 5/09 Sparc 
system using Sun Studio 12 Update 1 compiler. No CFLAGS or CXXFLAGS
have been set.

--($ ~/Source/libxml2-2.7.6/.32.)-- env | grep ^C
CXX=/opt/sunstudio12.1/bin/CC
CC=/opt/sunstudio12.1/bin/cc

Any idea about what might be wrong?

Searching the list, I found an /ancient/ mail from 3 years, 28 weeks, 
1 day, 1 hour and 10 minutes ago *G* on
http://thread.gmane.org/gmane.comp.gnome.lib.xml.general/11165/focus=11169

However, according to Daniels answer from way back then, "Bill"
commited some patch.

I fiddled now with relaxng:

--- ../relaxng.c-kaputt_:-(     Di Nov 17 16:14:40 2009
+++ ../relaxng.c        Di Nov 17 16:15:23 2009
@@ -5369,7 +5369,7 @@
     } else {
         xmlRngPErr(ctxt, node, XML_RNGP_CHOICE_CONTENT,
                    "expecting name, anyName, nsName or choice : got %s\n",
-                   (node == NULL ? "nothing" : node->name), NULL);
+                   (node == NULL ? BAD_CAST "nothing" : node->name), NULL);
         return (NULL);
     }
     if (ret != def) {

<http://pastebin.ca/1674944>

Now it compiles, I think - but I get a sh*tload of "symbol referencing"
errors -> http://pastebin.ca/1674946 . Unsure if they are related?

Well, I'd VERY much appreciate, if someone more knowledgeable could
please have a look ;)

Thanks a lot,
Alexander

_______________________________________________
xml mailing list, project page  http://xmlsoft.org/
xml@gnome.org
http://mail.gnome.org/mailman/listinfo/xml

Reply via email to