On Thu, 2018-04-12 at 19:04 +1000, Adam Nielsen wrote:
> > 
> > I can't seem to get XMMS2 to save a URL for an icecast stream. For
> > instance:
> Ha, wouldn't you know it, you are getting the same error as me and I
> thought it was unrelated.
> 
> It's definitely a bug in XMMS2 and the issue is here:
> 
> 08:54:27 DEBUG: ../src/xmms/xform.c:1164: Plugin 'vorbis' matched
> (priority 50)
> 08:54:27 DEBUG: ../src/xmms/xform.c:1032: Seek not implemented in
> 'curl'
> 08:54:27 DEBUG: ../src/xmms/xform.c:349: Freeing xform 'vorbis'
> 
> The logs show that it is starting to stream the audio just fine, but
> then for some reason it tries to seek back to the beginning of the
> data
> (which the curl plugin does not support for obvious reasons - you
> can't
> seek backwards in an uncached live stream) but for some reason this
> is
> enough to completely break the process and it gives up (freeing the
> only xform that can do the job of performing playback.)
> 
> I'll see if I can have a look at fixing this, but in the meantime, do
> you think you can have a go at compiling the git version of
> XMMS2?  Any
> potential fixes will be to the git version rather than 0.8.  The
> process will be much the same as you've already done, you'll just be
> running a "git clone ..." for the xmms2-devel repository instead of
> whatever method you used before to obtain the source code.
> 

Went here - git clone git://git.xmms2.org/xmms2/xmms2-devel.git then 

https://pastebin.com/higtc6yh

Everything looked ok this time as far as I can tell. Output of xmms2d
-vvv

https://pastebin.com/FEa0AjLy

Tried adding 
http://icecast-beta.timlradio.co.uk/absoluteclassicrock.ogg or

$ xmms2 add http://icecast-beta.timlradio.co.uk/absoluteclassicrock.ogg
chris@localhost:~$ xmms2 list
  [1/2] RAINBOW - Stranded (04:32)
  [2/3] RAINBOW - Can't Let You Go (04:24)
  [3/4] RAINBOW - Fool For The Night (04:07)

http://network.absoluteradio.co.uk/core/audio/oggflac/live.pls?service=
ac

$ xmms2 add http://network.absoluteradio.co.uk/core/audio/oggflac/live.
pls?service=ac
chris@localhost:~$ xmms2 list
  [1/2] RAINBOW - Stranded (04:32)
  [2/3] RAINBOW - Can't Let You Go (04:24)
  [3/4] RAINBOW - Fool For The Night (04:07)

neither worked.

-- 
Chris
KeyID 0xE372A7DA98E6705C
31.11972; -97.90167 (Elev. 1092 ft)
11:01:17 up 2 days, 1:01, 1 user, load average: 2.02, 1.49, 1.28
Description:    Ubuntu 16.04.4 LTS, kernel 4.13.0-38-generic

Attachment: signature.asc
Description: This is a digitally signed message part

--
_______________________________________________
Xmms2-devel mailing list
Xmms2-devel@lists.xmms2.org
https://lists.xmms2.org/cgi-bin/mailman/listinfo/xmms2-devel

Reply via email to