On Wed, 2010-10-06 at 17:14 -0700, Jeremy Huddleston wrote:

> Signed-off-by: Jeremy Huddleston <[email protected]>
> ---
>  Makefile.am  |    2 +-
>  configure.ac |    7 ++++---
>  2 files changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/Makefile.am b/Makefile.am
> index 34d9819..f1fc0cc 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -36,7 +36,7 @@ FONT_FILES = \
>  fontdir = @FONTDIR@
>  font_DATA = $(FONT_FILES)
>  
> -fontconfigdir = $(sysconfdir)/fonts
> +fontconfigdir = @FC_CONFDIR@
>  actualconfigdir = $(fontconfigdir)/conf.d
>  availconfigdir = $(fontconfigdir)/conf.avail
>  dist_availconfig_DATA = 42-luxi-mono.conf
> 


Reviewed-by: Gaetan Nadon <[email protected]>

Just a nit, it could be simplified:

        actualconfigdir = $(FC_CONFDIR)/conf.d
        availconfigdir = $(FC_CONFDIR)/conf.avail

There is no need to define a variable with the "dir" suffix as something
like fontconfig_DATA is not used. It's nice to keep the variables with
dir suffix
for those who participate in the Automake "uniform naming scheme".


Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
[email protected]: X.Org development
Archives: http://lists.x.org/archives/xorg-devel
Info: http://lists.x.org/mailman/listinfo/xorg-devel

Reply via email to