Dave Airlie <[email protected]> writes: (the fact that this change ends with a net loss of code is a definite bonus...)
> xf86: change EnterVT/LeaveVT to take a ScrnInfoPtr (ABI/API break) > xf86: modify FreeScreen callback to take pScrn instead of index. > (ABI/API) > xf86: move AdjustFrame to passing ScrnInfoPtr (ABI/API) > xf86: migrate SwitchMode to taking ScrnInfoPtr (ABI/API) Can you remove the 'flags' arguments at the same time? I can't see any use of it for any of these functions. > xserver: drop index argument to ScreenInit (ABI/API) (v2) Has this been built on Windows/MacOS? I'm sure Jeremy and one of the xwin folks would be happy to check to make sure things work before merging to master and getting surprised. > int10: cleanup one unnecessary use of xf86Screens > int10/vbe: don't use xf86Screens. (ABI) (v2) Could we change xf86DrvMsg* to take pScrn? Or is that too scary a change? Also, looking at int10/linux.c -- that code sets pInt->scrnIndex, but I can't see a change to that in this patch? Either I'm missing something (easy today, I'm afraid), or the linux.c code isn't used... > vbe: don't use index for VBEInterpretPanelID (API) > int10/linux: drop use of xf86Screens from linux specific int10 code (see above, shouldn't be assigning pInt->scrnIndex = screen). > xserver: convert block/wakeup handlers to passing ScreenPtr (ABI/API) > (v2) The doc change doesn't update the name of the Block/Wakeup handler argument from 'nscreen' to 'pScreen'. > xf86: make xf86DeleteScreen take a ScrnInfoPtr Another function with an unused 'flags' argument. The rest of the patches look good to me. And, as you can see above, my comments are mostly bikeshedding anyways. -- [email protected]
pgpRl9QlCWAzk.pgp
Description: PGP signature
_______________________________________________ [email protected]: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel
