Hi, On 28 November 2014 at 06:02, Peter Hutterer <[email protected]> wrote:
> On Mon, Nov 24, 2014 at 10:17:33PM +0000, Daniel Stone wrote: > diff --git a/Xi/exevents.c b/Xi/exevents.c > > index b0bc47e..cd2924a 100644 > > --- a/Xi/exevents.c > > +++ b/Xi/exevents.c > > @@ -810,6 +810,7 @@ UpdateDeviceState(DeviceIntPtr device, DeviceEvent > *event) > > case ET_ButtonPress: > > case ET_ButtonRelease: > > case ET_KeyPress: > > + case ET_KeyFocusIn: > > I would honestly prefer some different name. We do real focus in events, > I'd > like to avoid potential confusion here. How about ET_ServerFocusIn? > Yeah. I was going to use ET_KeymapNotify since that matches the relevant X11 event, but that is literally the worst-named event in the entire protocol. > > diff --git a/xkb/xkbActions.c b/xkb/xkbActions.c > > index c6cbf56..c075115 100644 > > --- a/xkb/xkbActions.c > > +++ b/xkb/xkbActions.c > > @@ -1144,9 +1144,10 @@ _XkbEnsureStateChange(XkbSrvInfoPtr xkbi) > > } > > > > static void > > -_XkbApplyState(DeviceIntPtr dev, Bool genStateNotify, int evtype, int > key) > > +_XkbApplyState(DeviceIntPtr dev, Bool genStateNotify, int evtype_int, > int key) > > .. Bool genStateNotify, enum EventType evtype, int key) > > we have an enum, use it, it's much more expressive than "int evtype_int". > coincidentally, storage is cheap enough these days that we could, on > average, afford to add "internal" instead of just "int". Yeah, my bad. Will fix up all the rest, but I guess it's basically all pending on what falls out of 3/3. Up to you; I don't really mind (or think it makes any difference tbh) either way. Cheers, Dan
_______________________________________________ [email protected]: X.Org development Archives: http://lists.x.org/archives/xorg-devel Info: http://lists.x.org/mailman/listinfo/xorg-devel
