Mario Kleiner <mario.kleiner...@gmail.com> writes:

> argb2101010 and xrgb2101010. Seems to work fine,
> but not sure if because of dumb luck or because
> it is meant to be. (Re)viewer discretion advised!
>
> Tested on KDE Plasma-5 with XRender based composite
> acceleration backend. Much smoother and faster.
>
> Signed-off-by: Mario Kleiner <mario.kleiner...@gmail.com>
> ---
>  glamor/glamor_render.c | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/glamor/glamor_render.c b/glamor/glamor_render.c
> index 7a96c82..659537f 100644
> --- a/glamor/glamor_render.c
> +++ b/glamor/glamor_render.c
> @@ -773,6 +773,8 @@ static Bool
>  glamor_render_format_is_supported(PictFormatShort format)
>  {
>      switch (format) {
> +    case PICT_a2r10g10b10:
> +    case PICT_x2r10g10b10:

I don't think you can include a2r10g10b10 here.  A pixmap that you've
attached that pictformat to must be depth 32, which will have been
created as an 8888 GL texture.  Doing composite on that when asked for
2101010 formatwill end up referencing the wrong bits in the color
channels.  I think if you ran rendercheck, it would throw errors about
this.

Other than that, patch 2-5 get my reviewed-by, except that we should
stack the glamor fixes before enabling the feature in the modesetting
driver.

Attachment: signature.asc
Description: PGP signature

_______________________________________________
xorg-devel@lists.x.org: X.Org development
Archives: http://lists.x.org/archives/xorg-devel
Info: https://lists.x.org/mailman/listinfo/xorg-devel

Reply via email to