Regarding this bug, I think the CapillaryTriaxialTest preprocessor does not add 
much to Yade now (even in a working state), and propose to remove 
CapillaryTriaxialTest.*pp from the code.
Either using git rm, or adding #ifdef DEPREC_CODE (I vote for the former)

Agree ?

You received this bug notification because you are a member of Yade
developers, which is subscribed to Yade.

  CapillaryTriaxialTest preprocessor broken

Status in Yade:

Bug description:

  When using either yadedaily or the latest (as of today) trunk version,
  CapillaryTriaxialTest preprocessor crashes at the first iteration. The
  backtrace obtained from a debug version of trunk is attached.

  I'm at the moment playing with capillary code before commit capillary
  scripts, but this crash happens with or without the "water" attribute
  of the preprocessor, ie with or without capillary Law2 in the engines,
  and with both yadedaily and trunk, so I do not think it's related.

  The crash occurs by the way during some IGeom operations, and the
  structure of O.engines defined by the preprocessor looks quite
  outdated (no InteractionLoop()).

  Anyway, I would happily hear from you that the same bug exists on
  other computers.


To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to