Public bug reported:

Hi,

we have our swift proxy configured with account_autocreate = false
(which is the default), i.e. a new project does not automatically have a
swift account, but it needs to be created via PUT on the swift auth url.

In combination with multi-tenant swift backend use in glance that means, that 
new projects cannot create images. Image creation in-transparently fails with a 
500 internal server error.
This is visible in the logs as "Failed to add container to Swift.
Got error from Swift: Container PUT failed [...] 404 Not Found".

We are running mitaka.

I think glance should try to create the swift account on that error.
It even could ask swift, whether the account_autocreate option is set (via 
/info, see 
http://developer.openstack.org/api-ref/object-storage/index.html#list-activated-capabilities).

If account creation is not an option, a more transparent error would be
good to hint the end-user that a swift account is missing.

Thanks,
Maurice

P.S. This also holds true when you only have one swift container to
store all your images, but it's not as big a problem because swift
account creation then is a one-time only task.

** Affects: glance
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to Glance.
https://bugs.launchpad.net/bugs/1632263

Title:
  swift backend not working with disabled swift auto account creation

Status in Glance:
  New

Bug description:
  Hi,

  we have our swift proxy configured with account_autocreate = false
  (which is the default), i.e. a new project does not automatically have
  a swift account, but it needs to be created via PUT on the swift auth
  url.

  In combination with multi-tenant swift backend use in glance that means, that 
new projects cannot create images. Image creation in-transparently fails with a 
500 internal server error.
  This is visible in the logs as "Failed to add container to Swift.
  Got error from Swift: Container PUT failed [...] 404 Not Found".

  We are running mitaka.

  I think glance should try to create the swift account on that error.
  It even could ask swift, whether the account_autocreate option is set (via 
/info, see 
http://developer.openstack.org/api-ref/object-storage/index.html#list-activated-capabilities).

  If account creation is not an option, a more transparent error would
  be good to hint the end-user that a swift account is missing.

  Thanks,
  Maurice

  P.S. This also holds true when you only have one swift container to
  store all your images, but it's not as big a problem because swift
  account creation then is a one-time only task.

To manage notifications about this bug go to:
https://bugs.launchpad.net/glance/+bug/1632263/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to