What is the value of the transport_url in the nova_api.cell_mappings
database table when this fails?

Is it
"rabbit://nova:nova_pass@192.168.110.1:5672,nova:nova_pass@192.168.110.2:5672,nova:nova_pass@192.168.110.3:5672/nova_vhost"?

** Changed in: nova
       Status: Invalid => New

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to OpenStack Compute (nova).
https://bugs.launchpad.net/bugs/1717915

Title:
  nova services and transport_url, cannot connect to vhost if specified

Status in OpenStack Compute (nova):
  New
Status in oslo.messaging:
  New

Bug description:
  Centos 7
  RDO installation

  After upgrading from newton to ocata, i configured transport_url as:
  transport_url = 
rabbit://nova:nova_pass@192.168.110.1:5672,nova:nova_pass@192.168.110.2:5672,nova:nova_pass@192.168.110.3:5672/nova_vhost

  and I removed [oslo_messaging_rabbit]

  But then the services din't start and I could ofcourse launch an
  instance.

  Rabbitmq-logs:

  =ERROR REPORT==== 18-Sep-2017::14:30:17 ===
  Error on AMQP connection <0.24592.64> (192.168.110.2:51662 -> 
192.168.110.2:5672 - nova-conductor:13053:a5fd524a-b479-4dbb-b8e5-4dd46bf8da74, 
user: 'nova', state: opening):
  access to vhost 'nova' refused for user 'nova'

  nova-conductor logs:

  2017-09-18 13:59:58.600 27799 ERROR oslo_service.service NotAllowed:
  Connection.open: (530) NOT_ALLOWED - access to vhost 'nova' refused
  for user 'nova'

  When I removed the transport_url and reconfigured the
  [oslo_messaging_rabbit] section the services started but again I
  couldnt launch n instance with the same error logs :

  [oslo_messaging_rabbit]
  rabbit_hosts = 192.168.110.1:5672,192.168.110.2:5672,192.168.110.3:5672
  rabbit_userid = "nova"
  rabbit_password = "nova_pass"
  rabbit_virtual_host = "/nova_vhost"

  
  Finaly I reconfigured transport_url removed the /nova_vhost from the end, 
gave access to nova user for / vhost and everything worked. Keep in mind that 
of course nova user had access to /nova_vhost before. I also did cell_v2 update 
to update the transport_url in the db.

To manage notifications about this bug go to:
https://bugs.launchpad.net/nova/+bug/1717915/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to