Dan,
I've tried to recreate this issue and I'm not able to.
Your log shows:

2017-10-05 09:46:15,582 - openstack.py[DEBUG]: Failed reading optional
path /tmp/tmpB4Bmvi/openstack/2015-10-15/network_data.json due to:
[Errno 2] No such file or directory:
'/tmp/tmpB4Bmvi/openstack/2015-10-15/network_data.json'

which is inconsistent wit the tar file you sent.  the tar file has a
'network_data.json'.

All in all, I don't think this is an issue any more. I'm going to go ahead and 
mark the bug fixed in 17.1.
If you are able to reproduce error and your log contains something like:

2017-10-05 09:46:15,654 - DataSourceConfigDrive.py[DEBUG]: network
config provided via converted eni data


then please attach the *full* config drive (dd if=/dev/sr0 of=out.img && gzip 
out.img) and /var/log/cloud-init.log
and just please open a new bug with that information.

Thanks.

** Changed in: cloud-init
       Status: Incomplete => Fix Released

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to cloud-init.
https://bugs.launchpad.net/bugs/1671927

Title:
  init local crash - unknown subnet type 'loopback'

Status in cloud-init:
  Fix Released
Status in cloud-init package in CentOS:
  In Progress

Bug description:
  cloud-init-0.7.8-5.fc25.noarch on Fedora 25
  Data source: ConfigDrive
  Cloud provider: Openstack

  Local init ($ cloud-init init -l) crashes with error [Unknown subnet
  type 'loopback' found for interface 'lo'].  Stack trace attached.

  I have a config drive w/ Ubuntu-style interface file at
  sr0/openstack/content/0000, and network_data.json at
  sr0/openstack/latest/.  Only 0000 defines the loopback device.
  Screenshots of these files are at http://imgur.com/a/qEElh.

  Expected outcome is to render ifcfg-eth0 in /etc/sysconfig/network-
  scripts, but leave ifcfg-lo in that directory untouched as per
  previous versions, for instance cloud-
  init-0.7.6-5.20140218bzr1060.fc23.noarch on Fedora 23.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-init/+bug/1671927/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to