run_tests.sh was dropped in Queens. We don't fix anymore even if there
was a problem related to run_tests.sh.

** Changed in: horizon
    Milestone: next => None

** Changed in: horizon
       Status: Confirmed => Won't Fix

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to OpenStack Dashboard (Horizon).
https://bugs.launchpad.net/bugs/1461238

Title:
  Following QuickStart instructions, "run_test.sh" fails with "Please
  install 'python-virtualenv'", which doesn't exist as a yum package

Status in OpenStack Dashboard (Horizon):
  Won't Fix

Bug description:
  I'm trying to check out and build Horizon so I can investigate some
  changes.

  I'm following the instructions at
  http://docs.openstack.org/developer/horizon/quickstart.html .

  I'm using a CentOS 6.6 VM.

  When I ran "./run_tests.sh", it said this:
  --------------------------------
  % ./run_tests.sh 
  Checking environment.
  Environment not found. Install? (Y/n) y
  Fetching new src packages...
  which: no virtualenv in 
(/home/dk068x/frameworks/node-v0.10.32-linux-x64/bin:/home/dk068x/frameworks/gradle-2.3/bin:/home/dk068x/frameworks/apache-ant-1.9.3/bin:/home/dk068x/frameworks/apache-maven-3.2.1/bin:/home/dk068x/bin:/home/dk068x/frameworks/groovy-2.4.1/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin)
  Please install 'python-virtualenv'.
  -------------------------------------

  This is curious, because I pasted the earlier "yum install" line as described 
in the page.  I ran it again:
  ----------------------------
  % sudo yum install gcc git-core python-devel python-virtualenv openssl-devel 
libffi-devel which
  Loaded plugins: fastestmirror, refresh-packagekit, security
  Setting up Install Process
  Loading mirror speeds from cached hostfile
  Package gcc-4.4.7-11.el6.x86_64 already installed and latest version
  Package git-1.7.1-3.el6_4.1.x86_64 already installed and latest version
  Package python-devel-2.6.6-52.el6.x86_64 already installed and latest version
  No package python-virtualenv available.
  Package openssl-devel-1.0.1e-30.el6_6.5.x86_64 already installed and latest 
version
  Package libffi-devel-3.0.5-3.2.el6.x86_64 already installed and latest version
  Package which-2.19-6.el6.x86_64 already installed and latest version
  Nothing to do
  -----------------------------

  Is there another repo I'm supposed to be configuring here?

To manage notifications about this bug go to:
https://bugs.launchpad.net/horizon/+bug/1461238/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to