Public bug reported:

Delorean Newton (CentOS 7) ships with noVNC 0.5.2 in the Overcloud
images. Even building an Overcloud image (DIB) produces an image with
noVNC 0.5.2. The problem seems to be that CentOS 7 does not ship
anything newer than 0.5.2. However, Red Hat Enterprise Linux 7 does
indeed ship noVNC 0.6.

In any case, Nova noVNC consoles in Newton don't work with noVNC 0.5.2.
My workaround was to customize the Overcloud base image and replace the
0.5.2 RPM with a 0.6.2 RPM that I downloaded from some CentOS CI
repository.

Steps to reproduce
==================

Follow instructions from 
https://docs.openstack.org/tripleo-docs/latest/install/installation/installing.html
 to install an OpenStack Undercloud using Newton, and either download the 
Overcloud base images from here 
https://images.rdoproject.org/newton/delorean/consistent/testing/ or build them 
yourself directly from the Undercloud.

In any case, the Overcloud base image ships with noVNC 0.5.2-1 instead
of 0.6.*.

Expected result
===============

A newer version of noVNC that does not break the Nova noVNC console.

** Affects: nova
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to OpenStack Compute (nova).
https://bugs.launchpad.net/bugs/1752896

Title:
  novncproxy in Newton uses outdated novnc 0.5 which breaks Nova noVNC
  consoles

Status in OpenStack Compute (nova):
  New

Bug description:
  Delorean Newton (CentOS 7) ships with noVNC 0.5.2 in the Overcloud
  images. Even building an Overcloud image (DIB) produces an image with
  noVNC 0.5.2. The problem seems to be that CentOS 7 does not ship
  anything newer than 0.5.2. However, Red Hat Enterprise Linux 7 does
  indeed ship noVNC 0.6.

  In any case, Nova noVNC consoles in Newton don't work with noVNC
  0.5.2. My workaround was to customize the Overcloud base image and
  replace the 0.5.2 RPM with a 0.6.2 RPM that I downloaded from some
  CentOS CI repository.

  Steps to reproduce
  ==================

  Follow instructions from 
https://docs.openstack.org/tripleo-docs/latest/install/installation/installing.html
 to install an OpenStack Undercloud using Newton, and either download the 
Overcloud base images from here 
  https://images.rdoproject.org/newton/delorean/consistent/testing/ or build 
them yourself directly from the Undercloud.

  In any case, the Overcloud base image ships with noVNC 0.5.2-1 instead
  of 0.6.*.

  Expected result
  ===============

  A newer version of noVNC that does not break the Nova noVNC console.

To manage notifications about this bug go to:
https://bugs.launchpad.net/nova/+bug/1752896/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to