Public bug reported:

Description
===========
When the instance X's hosting Compute H is down, ry to rebuild instance is 
stuck is "REBUILD" status forever.

Steps to reproduce
==================
* Create instance X on Compute H
* Power off Compute H
* Rebuild instance X (with same image)

$ openstack server rebuild X

Expected result
===============
The instance X should fails to rebuild on the same host with proper error 
message.

Actual result
=============
The instance is in "REBUILD" state forever.

Environment
===========
1. Queens release used.

   $ rpm -qa | grep nova-compute
     openstack-nova-compute-17.0.5-1

2. KVM hypervisor
   qemu-kvm-common-ev-2.10.0-21
   libvirt-daemon-kvm-3.9.0-14.1

2. LVM used as storage backend on Compute host.
   lvm2-2.02.177-4

3. Which networking type did you use?
   Neutron with OpenVSwitch

** Affects: nova
     Importance: Undecided
         Status: New


** Tags: rebuild

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to OpenStack Compute (nova).
https://bugs.launchpad.net/bugs/1801714

Title:
  Rebuild instance is stuck in rebuilding state when hosting Compute is
  powered off

Status in OpenStack Compute (nova):
  New

Bug description:
  Description
  ===========
  When the instance X's hosting Compute H is down, ry to rebuild instance is 
stuck is "REBUILD" status forever.

  Steps to reproduce
  ==================
  * Create instance X on Compute H
  * Power off Compute H
  * Rebuild instance X (with same image)

  $ openstack server rebuild X

  Expected result
  ===============
  The instance X should fails to rebuild on the same host with proper error 
message.

  Actual result
  =============
  The instance is in "REBUILD" state forever.

  Environment
  ===========
  1. Queens release used.

     $ rpm -qa | grep nova-compute
       openstack-nova-compute-17.0.5-1

  2. KVM hypervisor
     qemu-kvm-common-ev-2.10.0-21
     libvirt-daemon-kvm-3.9.0-14.1

  2. LVM used as storage backend on Compute host.
     lvm2-2.02.177-4

  3. Which networking type did you use?
     Neutron with OpenVSwitch

To manage notifications about this bug go to:
https://bugs.launchpad.net/nova/+bug/1801714/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to