Looks like some kind of misconfiguration. You're trying to create a
flavor and nova-api is trying to call keystone to validate the token
using the keystone auth token middleware, and that is failing because
something is misconfigured. Check the install docs and config docs:

https://docs.openstack.org/nova/latest/configuration/config.html
#keystone-authtoken

https://docs.openstack.org/nova/latest/install/controller-install-
ubuntu.html

** Changed in: nova
       Status: New => Invalid

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to OpenStack Compute (nova).
https://bugs.launchpad.net/bugs/1801326

Title:
  CRITICAL keystonemiddleware.auth_token

Status in OpenStack Compute (nova):
  Invalid

Bug description:
  Hi

  I am facing issue with dashboard (flavors function) and also command line 
when creating new flavor.
  Error (nova-api log):

  ----
  2018-11-02 11:43:24.448 7149 INFO nova.osapi_compute.wsgi.server [-] 
194.24.226.85 "POST /v2.1/b09e14755fcb47f897c55681c8ef73ff/flavors HTTP/1.1" 
status: 503 len: 399 time: 0.0385082
  2018-11-02 11:44:13.895 7143 WARNING keystonemiddleware.auth_token [-] Using 
the in-process token cache is deprecated as of the 4.2.0 release and may be 
removed in the 5.0.0 release or the 'O' development cycle. The in-process cache 
causes inconsistent results and high memory usage. When the feature is removed 
the auth_token middleware will not cache tokens by default which may result in 
performance issues. It is recommended to use  memcache for the auth_token token 
cache by setting the memcached_servers option.
  2018-11-02 11:44:13.919 7143 ERROR keystonemiddleware.auth_token [-] Bad 
response code while validating token: 400
  2018-11-02 11:44:13.929 7143 WARNING keystonemiddleware.auth_token [-] 
Identity response: {"error": {"message": "Invalid input for field 
'identity/password/user/password': None is not of type 'string'", "code": 400, 
"title": "Bad Request"}}
  2018-11-02 11:44:13.930 7143 CRITICAL keystonemiddleware.auth_token [-] 
Unable to validate token: Failed to fetch token data from identity server
  2018-11-02 11:44:13.932 7143 INFO nova.osapi_compute.wsgi.server [-] 
194.24.226.85 "POST /v2.1/b09e14755fcb47f897c55681c8ef73ff/flavors HTTP/1.1" 
status: 503 len: 399 time: 0.0378041
  ----

  I have checked a lot of community posts and bugs raports but cannot
  get rid of issue. Tried several methods. v2 api etc. Checked that
  username and pw works for nova.

  Configure paste: http://paste.openstack.org/show/733950/

To manage notifications about this bug go to:
https://bugs.launchpad.net/nova/+bug/1801326/+subscriptions

-- 
Mailing list: https://launchpad.net/~yahoo-eng-team
Post to     : yahoo-eng-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yahoo-eng-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to