Adam Antal created YARN-9856:
--------------------------------
Summary: Remove log-aggregation related duplicate function
Key: YARN-9856
URL: https://issues.apache.org/jira/browse/YARN-9856
Project: Hadoop YARN
Issue Type: Task
Components: log-aggregation, yarn
Affects Versions: 3.3.0
Reporter: Adam Antal
[~snemeth] has noticed a duplication in two of the log-aggregation related
functions.
{quote}I noticed duplicated code in
org.apache.hadoop.yarn.logaggregation.LogToolUtils#outputContainerLog,
duplicated in
org.apache.hadoop.yarn.logaggregation.AggregatedLogFormat.LogReader#readContainerLogs.
[...]
{quote}
We should remove the duplication.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]