Steve Loughran updated YARN-746:

    Attachment: YARN-746-001.patch

Patch -designed to go in after the big YARN-117 commit -it updates the new 
> rename Service.register() and Service.unregister() to 
> registerServiceListener() & unregisterServiceListener() respectively
> --------------------------------------------------------------------------------------------------------------------------
>                 Key: YARN-746
>                 URL: https://issues.apache.org/jira/browse/YARN-746
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Steve Loughran
>         Attachments: YARN-746-001.patch
> make it clear what you are registering on a {{Service}} by naming the methods 
> {{registerServiceListener()}} & {{unregisterServiceListener()}} respectively.
> This only affects a couple of production classes; {{Service.register()}} and 
> is used in some of the lifecycle tests of the YARN-530. There are no tests of 
> {{Service.unregister()}}, which is something that could be corrected.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to