[ 
https://issues.apache.org/jira/browse/YARN-749?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13672636#comment-13672636
 ] 

Sandy Ryza commented on YARN-749:
---------------------------------

+1, have thought this would be a good change for a while.

Will the field ever include anything that's not host, rack, or *?  If not, 
something like setLocation or setLocationName might be more descriptive?
                
> Rename ResourceRequest (get,set)HostName to (get,set)ResourceName
> -----------------------------------------------------------------
>
>                 Key: YARN-749
>                 URL: https://issues.apache.org/jira/browse/YARN-749
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Arun C Murthy
>            Assignee: Arun C Murthy
>              Labels: api-change
>
> We should rename ResourceRequest (get,set)HostName to (get,set)ResourceName 
> since the name can be host, rack or *.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to