Yufei Gu commented on YARN-6971:

Thanks [~sunilg] for the details. I can't think about more to share.
In that sense, we are not only replace unnecessary 
{{BuilderUtils.newResource()}}, but also need to change its name to something 
like {{createResourceForRPC()}} or at least document when to use 
{{BuilderUtils.newResource()}} and when to use others.

Do you think this jira should be a subtask of YARN-3926? I assume there is no 
duplicate one.

> Clean up different ways to create resources
> -------------------------------------------
>                 Key: YARN-6971
>                 URL: https://issues.apache.org/jira/browse/YARN-6971
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager, scheduler
>            Reporter: Yufei Gu
>            Priority: Minor
>              Labels: newbie
> There are several ways to create a {{resource}} object, e.g., 
> BuilderUtils.newResource() and Resources.createResource(). These methods not 
> only cause confusing but also performance issues, for example 
> BuilderUtils.newResource() is significant slow than 
> Resources.createResource(). 
> We could merge them some how, and replace most BuilderUtils.newResource() 
> with Resources.createResource().

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to