Jian He commented on YARN-6413:

So the registry path is currently like this:
{code}, see 

For native-service, ApplicationServiceRecordKey#appId will need to be appName 
and ContainerServiceRecordKey#containerId will need to be containerName, 
probably rename it to be containerKey or appKey ?
And the new method RegistryUtil#getPathForServiceRecordKey, the generated path 
is inconsistent with the document - which will beak the callers of registry 
API. Could you make it in consistent with the document ?

> Decouple Yarn Registry API from ZK
> ----------------------------------
>                 Key: YARN-6413
>                 URL: https://issues.apache.org/jira/browse/YARN-6413
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: amrmproxy, api, resourcemanager
>            Reporter: Ellen Hui
>            Assignee: Ellen Hui
>         Attachments: 0001-Registry-API-v2.patch, 0002-Registry-API-v2.patch, 
> 0003-Registry-API-api-only.patch, 0004-Registry-API-api-stubbed.patch
> Right now the Yarn Registry API (defined in the RegistryOperations interface) 
> is a very thin layer over Zookeeper. This jira proposes changing the 
> interface to abstract away the implementation details so that we can write a 
> FS-based implementation of the registry service, which will be used to 
> support AMRMProxy HA.
> The new interface will use register/delete/resolve APIs instead of 
> Zookeeper-specific operations like mknode. 

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to