[ 
https://issues.apache.org/jira/browse/YARN-7136?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16160526#comment-16160526
 ] 

Daniel Templeton commented on YARN-7136:
----------------------------------------

Looking better.  Not loving the ternaries, though.  In the case of 
{{LightWeightResource}}, the ternary follows an _if_.  Seems awkward not to 
just continue with an _else-if_.  In the case of {{Resource}} the ternary 
actually adds an extra comparison over _if-greater-else-if-less_.  Can we just 
make them regular old _if_ and _else_ statements?

> Additional Performance Improvement for Resource Profile Feature
> ---------------------------------------------------------------
>
>                 Key: YARN-7136
>                 URL: https://issues.apache.org/jira/browse/YARN-7136
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager, resourcemanager
>            Reporter: Wangda Tan
>            Assignee: Wangda Tan
>            Priority: Critical
>         Attachments: YARN-7136.001.patch, YARN-7136.YARN-3926.001.patch, 
> YARN-7136.YARN-3926.002.patch, YARN-7136.YARN-3926.003.patch, 
> YARN-7136.YARN-3926.004.patch, YARN-7136.YARN-3926.005.patch, 
> YARN-7136.YARN-3926.006.patch, YARN-7136.YARN-3926.007.patch, 
> YARN-7136.YARN-3926.008.patch, YARN-7136.YARN-3926.009.patch, 
> YARN-7136.YARN-3926.010.patch, YARN-7136.YARN-3926.011.patch, 
> YARN-7136.YARN-3926.012.patch, YARN-7136.YARN-3926.013.patch, 
> YARN-7136.YARN-3926.014.patch
>
>
> This JIRA is plan to add following misc perf improvements:
> 1) Use final int in Resources/ResourceCalculator to cache 
> #known-resource-types. (Significant improvement).
> 2) Catch Java's ArrayOutOfBound Exception instead of checking array.length 
> every time. (Significant improvement).
> 3) Avoid setUnit validation (which is a HashSet lookup) when initialize 
> default Memory/VCores ResourceInformation (Significant improvement).
> 4) Avoid unnecessary loop array in Resource#toString/hashCode. (Some 
> improvement).
> 5) Removed readOnlyResources in BaseResource. (Minor improvement).
> 6) Removed enum: MandatoryResources, use final integer instead. (Minor 
> improvement).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to