Rohith Sharma K S commented on YARN-7346:

bq. so without uncommenting hadoop-yarn-dist.xml, the final artifact does not 
include the hbase-coprocessor jar when hbase.profile is 2.0.
It includes for hbase-2.0. But issue I see is assume we have built using 
hbase.profile=2.0 and later if we are going to build with default then 
hbase-2.0 will override hbase-1.2.6 co processor. If hbase-2/traget doesn't 
contains any artifacts then there is NO problem. But if it contains artifacts 
then package includes hbase-2 co-processor.

> Fix compilation errors against hbase2 beta release
> --------------------------------------------------
>                 Key: YARN-7346
>                 URL: https://issues.apache.org/jira/browse/YARN-7346
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Ted Yu
>            Assignee: Vrushali C
>            Priority: Major
>         Attachments: YARN-7346.00.patch, YARN-7346.01.patch, 
> YARN-7346.02.patch, YARN-7346.03-incremental.patch, YARN-7346.03.patch, 
> YARN-7346.04.patch, YARN-7346.prelim1.patch, YARN-7346.prelim2.patch, 
> YARN-7581.prelim.patch
> When compiling hadoop-yarn-server-timelineservice-hbase against 2.0.0-alpha3, 
> I got the following errors:
> https://pastebin.com/Ms4jYEVB
> This issue is to fix the compilation errors.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to