[ 
https://issues.apache.org/jira/browse/YARN-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16438059#comment-16438059
 ] 

Haibo Chen commented on YARN-7088:
----------------------------------

{quote}I update the launchTime only if it is non zero so I guess we are fine 
here?
{quote}
Sorry, I misunderstood the patch. But I am still not sure if we should add 
schedulingwait time and total run time. If an application have more than one 
attempts, and the following attempt(s) spend some time waiting to be scheduled, 
then the two metrics are not accurate. Thus, I'm inclined to not add them.

Besides, I have a few more minor comments.

1) The change to remove the period in ApplicationReport.getName() javadoc is 
unnecessary. That's why checkstyle is warning about this.

2) ApplicationReport.setLaunchTime should be marked as Private & Unstable, 
whereas getLaunchTime should be annotated with Public & Unstable, following the 
conventions

3) ApplicationMetricsConstants.APP_ATT_LAUNCHED_EVENT_TYPE is unused.

4) The name of  AppRunningOnAppAttemptLaunchTransition is misleading. How about 
we rename it to AttemptLaunchedTransition?

5) RMAppImpl.setLaunchTime() is not needed I think.

> Fix application start time and add submit time to UIs
> -----------------------------------------------------
>
>                 Key: YARN-7088
>                 URL: https://issues.apache.org/jira/browse/YARN-7088
>             Project: Hadoop YARN
>          Issue Type: Bug
>    Affects Versions: 3.0.0-alpha4
>            Reporter: Abdullah Yousufi
>            Assignee: Kanwaljeet Sachdev
>            Priority: Major
>         Attachments: YARN-7088.001.patch, YARN-7088.002.patch, 
> YARN-7088.003.patch, YARN-7088.004.patch, YARN-7088.005.patch, 
> YARN-7088.006.patch, YARN-7088.007.patch, YARN-7088.008.patch, 
> YARN-7088.009.patch, YARN-7088.010.patch, YARN-7088.011.patch, 
> YARN-7088.012.patch, YARN-7088.013.patch, YARN-7088.014.patch, 
> YARN-7088.015.patch
>
>
> Currently, the start time in the old and new UI actually shows the app 
> submission time. There should actually be two different fields; one for the 
> app's submission and one for its start, as well as the elapsed pending time 
> between the two.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to