[ 
https://issues.apache.org/jira/browse/YARN-8997?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16683193#comment-16683193
 ] 

Zhankun Tang commented on YARN-8997:
------------------------------------

[~giovanni.fumarola] , Sure. Thanks for the review. Will merge to one patch and 
submitted here.

> [Submarine] Simplify the logic in YarnServiceJobSubmitter#needHdfs
> ------------------------------------------------------------------
>
>                 Key: YARN-8997
>                 URL: https://issues.apache.org/jira/browse/YARN-8997
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Zhankun Tang
>            Assignee: Zhankun Tang
>            Priority: Minor
>         Attachments: YARN-8997-trunk-001.patch
>
>
> In YarnServiceJobSubmitter#needHdfs. Below code can be simplified to just one 
> line.
> {code:java}
> if (content != null && content.contains("hdfs://")) {
>   return true;
> }
> return false;{code}
> {code:java}
> return content != null && content.contains("hdfs://");{code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to