[ 
https://issues.apache.org/jira/browse/YARN-9560?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16869960#comment-16869960
 ] 

Eric Yang commented on YARN-9560:
---------------------------------

[~ebadger] Thanks for the update.  A few questions:

# DockerLinuxContainerRuntime Javadoc removed 
YARN_CONTAINER_RUNTIME_DOCKER_RUN_OVERRIDE_DISABLE and 
YARN_CONTAINER_RUNTIME_DOCKER_CONTAINER_NETWORK without listing them in OCI or 
Docker runtime.  Is this correct?  If yes, what is the reason to remove them?
# OCIRuntime list environment variable 
YARN_CONTAINER_RUNTIME_OCI_CONTAINER_PID_NAMESPACE_FMT.  This is a formatter 
string, not the actual environment variable.  User might get confused what 
exactly to specify because inconsistency between Javadoc for DockerRuntime and 
OCIRuntime.  How about document this in DockerRuntime, then link to OCIRuntime 
code that Jim suggested?

Maybe some way to shorten the long FMT variables?

{code}
static final String RUNTIME_PREFIX = "YARN_CONTAINER_RUNTIME_%s_%s";
String.format(RUNTIME_PREFIX, getEnvConfigType(), key); 
{code}

> Restructure DockerLinuxContainerRuntime to extend a new OCIContainerRuntime
> ---------------------------------------------------------------------------
>
>                 Key: YARN-9560
>                 URL: https://issues.apache.org/jira/browse/YARN-9560
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Eric Badger
>            Assignee: Eric Badger
>            Priority: Major
>              Labels: Docker
>         Attachments: YARN-9560.001.patch, YARN-9560.002.patch, 
> YARN-9560.003.patch, YARN-9560.004.patch, YARN-9560.005.patch, 
> YARN-9560.006.patch, YARN-9560.007.patch, YARN-9560.008.patch
>
>
> Since the new OCI/squashFS/runc runtime will be using a lot of the same code 
> as DockerLinuxContainerRuntime, it would be good to move a bunch of the 
> DockerLinuxContainerRuntime code up a level to an abstract class that both of 
> the runtimes can extend. 
> The new structure will look like:
> {noformat}
> OCIContainerRuntime (abstract class)
>   - DockerLinuxContainerRuntime
>   - FSImageContainerRuntime (name negotiable)
> {noformat}
> This JIRA should only change the structure of the code, not the actual 
> semantics



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to