[ 
https://issues.apache.org/jira/browse/YARN-9561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16888234#comment-16888234
 ] 

Eric Yang commented on YARN-9561:
---------------------------------

[~ebadger] A few more nits while reviewing patch 002:

# In setup_container_paths, it would be good to use fprintf instead of fputs 
and include the actual path location.  This helps system admin to debug the 
error more precisely.
# Can make_string be used instead of strbuf_append_fmt for readability reason 
and reduce the need of string format functions?  The 16k size seem like a limit 
that is easy to reach.  make_string may use more memory during string 
construction, but maybe it is safer?
# This part of code doesn't seem to have any effect:

{code}
  de = is_docker_support_enabled() ? enabled : disabled;
  fprintf(stream,
      "%11s launch docker container:      %2d appid containerid workdir "
      "container-script tokens pidfile nm-local-dirs nm-log-dirs "
      "docker-command-file resources ", de, LAUNCH_DOCKER_CONTAINER);
{code}

I haven't looked at memory management yet, may have better way to verify when 
test cases become available.

> Add C changes for the new RuncContainerRuntime
> ----------------------------------------------
>
>                 Key: YARN-9561
>                 URL: https://issues.apache.org/jira/browse/YARN-9561
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Eric Badger
>            Assignee: Eric Badger
>            Priority: Major
>         Attachments: YARN-9561.001.patch, YARN-9561.002.patch
>
>
> This JIRA will be used to add the C changes to the container-executor native 
> binary that are necessary for the new RuncContainerRuntime. There should be 
> no changes to existing code paths. 



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to