[ 
https://issues.apache.org/jira/browse/YARN-9679?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16908209#comment-16908209
 ] 

Hudson commented on YARN-9679:
------------------------------

FAILURE: Integrated in Jenkins build Hadoop-trunk-Commit #17130 (See 
[https://builds.apache.org/job/Hadoop-trunk-Commit/17130/])
YARN-9679. Regular code cleanup in TestResourcePluginManager (#1122) 
(954799+szilard-nemeth: rev 22c4f38c4b005a70c9b95d8aaa350763aaec5c5e)
* (edit) 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/resourceplugin/TestResourcePluginManager.java


> Regular code cleanup in TestResourcePluginManager
> -------------------------------------------------
>
>                 Key: YARN-9679
>                 URL: https://issues.apache.org/jira/browse/YARN-9679
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Szilard Nemeth
>            Assignee: Adam Antal
>            Priority: Major
>              Labels: newbie
>             Fix For: 3.3.0
>
>
> There are several things could be cleaned up in this class: 
> 1. stubResourcePluginmanager should be private.
> 2. In tearDown, the result of dest.delete() should be checked
> 3. In class CustomizedResourceHandler, there are several methods where 
> exceptions decalarations are unnecessary.
> 4. Class MyMockNM should be renamed to some more meaningful name.
> 5. There are some danling javadoc comments, for example: 
> {code:java}
> /*
>    * Make sure ResourcePluginManager is initialized during NM start up.
>    */
> {code}
> 6. There are some exceptions unnecessarily declared on test methods but they 
> are never thrown, an example: 
> testLinuxContainerExecutorWithResourcePluginsEnabled
> 7. Assert.assertTrue(false); expressions should be replaced with Assert.fail()
> 8. A handful of usages of Mockito's spy method. This method is not preferred 
> so we should think about replacing it with mocks, somehow.
> The rest can be figured out by whoever takes this jira :) 



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to