[ 
https://issues.apache.org/jira/browse/YARN-9998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Szilard Nemeth updated YARN-9998:
---------------------------------
    Description: 
Many thins can be improved:
* Field compactionTimer could be a local variable
* Field versiondb should be camelcase
* initDatabase is a very long method: Initialize db / versionDb should be in 
separate methods, split this method into smaller chunks
* Remove TODOs
* Remove duplicated code block in LeveldbConfigurationStore.CompactionTimerTask
* Any other cleanup

  was:
Many thins can be improved:
* znodeParentPath could be a local variable
* zkManager could be private, VisibleForTesting annotation is not needed anymore
* Do something with unchecked casts
* zkManager.safeSetData calls are almost having the same set of parameters: 
Simplify this
* Extract zkManager calls to their own methods: They are repeated
* Remove TODOs


> Code cleanup in LeveldbConfigurationStore
> -----------------------------------------
>
>                 Key: YARN-9998
>                 URL: https://issues.apache.org/jira/browse/YARN-9998
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Szilard Nemeth
>            Assignee: Szilard Nemeth
>            Priority: Minor
>
> Many thins can be improved:
> * Field compactionTimer could be a local variable
> * Field versiondb should be camelcase
> * initDatabase is a very long method: Initialize db / versionDb should be in 
> separate methods, split this method into smaller chunks
> * Remove TODOs
> * Remove duplicated code block in 
> LeveldbConfigurationStore.CompactionTimerTask
> * Any other cleanup



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to