Íñigo Goiri commented on YARN-8529:

We should fix most of the checkstyle issues.

I still think that adding a cast from long to int is worth for readability and 
using {{getTimeDuration()}} forces everything to be clear in terms of units.

> Add timeout to RouterWebServiceUtil#invokeRMWebService
> ------------------------------------------------------
>                 Key: YARN-8529
>                 URL: https://issues.apache.org/jira/browse/YARN-8529
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Íñigo Goiri
>            Assignee: Minni Mittal
>            Priority: Major
>         Attachments: YARN-8529.v1.patch, YARN-8529.v2.patch, 
> YARN-8529.v3.patch, YARN-8529.v4.patch
> {{RouterWebServiceUtil#invokeRMWebService}} currently has a fixed timeout. 
> This should be configurable.

This message was sent by Atlassian Jira

To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to