[ 
https://issues.apache.org/jira/browse/YARN-6492?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17100369#comment-17100369
 ] 

Jonathan Hung edited comment on YARN-6492 at 5/6/20, 1:14 AM:
--------------------------------------------------------------

OK thanks [~maniraj...@gmail.com] for the explanation. Sorry for the long 
delay, took some time to grok the latest 007 patch.
* Can we rename getPartitionQueueMetrics to something different? My initial 
confusion was that getPartitionQueueMetrics for QueueMetrics and 
PartitionQueueMetrics serve different purposes...the former for queue*partition 
and the latter for partition only. It's especially confusing in the case of 
PartitionQueueMetrics#getPartitionQueueMetrics, since this has nothing to do 
with queues. We can update the comment for 
PartitionQueueMetrics#getPartitionQueueMetrics as well, it also says Partition 
* Queue.
* Mentioned this earlier, can we remove the {noformat}   if (parent != null) {
              parent.setAvailableResourcesToUser(partition, user, limit);
            }{noformat}
check in QueueMetrics#setAvailableResourcesToUser?  I think it should be 
addressed here rather than YARN-9767.
* I don't think the asserts in TestNodeLabelContainerAllocation should change. 
leafQueue.getMetrics should return metrics for default partition. I think we 
still need to check in QueueMetrics#setAvailableResourcesToUser and 
QueueMetrics#setAvailableResourcesToQueue whether partition is null or empty 
string. (This will break updating partition queue metrics, so we need to find a 
way to distinguish whether we're updating default partition queue metrics or 
partitioned queue metrics.)
* Mentioned before, can we update everywhere we're creating a new metricName 
for partition/user/queue metrics to use a delimiter? e.g. {noformat}String 
metricName = partition + this.queueName + userName;{noformat}. Otherwise 
there's a chance that these metric names could collide.


was (Author: jhung):
OK thanks [~maniraj...@gmail.com] for the explanation. Sorry for the long 
delay, took some time to grok the latest 007 patch.
* Can we rename getPartitionQueueMetrics to something different? My initial 
confusion was that getPartitionQueueMetrics for QueueMetrics and 
PartitionQueueMetrics serve different purposes...the former for queue*partition 
and the latter for partition only. It's especially confusing in the case of 
PartitionQueueMetrics#getPartitionQueueMetrics, since this has nothing to do 
with queues. We can update the comment for 
PartitionQueueMetrics#getPartitionQueueMetrics as well, it also says Partition 
* Queue.
* Mentioned this earlier, can we remove the {noformat}   if (parent != null) {
              parent.setAvailableResourcesToUser(partition, user, limit);
            }{noformat}
check in QueueMetrics#setAvailableResourcesToUser?  I think it should be 
addressed here rather than YARN-9767.
* I don't think the asserts in TestNodeLabelContainerAllocation should change. 
leafQueue.getMetrics should return metrics for default partition. I think we 
still need to check in QueueMetrics#setAvailableResourcesToUser and 
QueueMetrics#setAvailableResour cesToQueue whether partition is null or empty 
string. (This will break updating partition queue metrics, so we need to find a 
way to distinguish whether we're updating default partition queue metrics or 
partitioned queue metrics.)
* Mentioned before, can we update everywhere we're creating a new metricName 
for partition/user/queue metrics to use a delimiter? e.g. {noformat}String 
metricName = partition + this.queueName + userName;{noformat}. Otherwise 
there's a chance that these metric names could collide.

> Generate queue metrics for each partition
> -----------------------------------------
>
>                 Key: YARN-6492
>                 URL: https://issues.apache.org/jira/browse/YARN-6492
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: capacity scheduler
>            Reporter: Jonathan Hung
>            Assignee: Manikandan R
>            Priority: Major
>         Attachments: PartitionQueueMetrics_default_partition.txt, 
> PartitionQueueMetrics_x_partition.txt, PartitionQueueMetrics_y_partition.txt, 
> YARN-6492.001.patch, YARN-6492.002.patch, YARN-6492.003.patch, 
> YARN-6492.004.patch, YARN-6492.005.WIP.patch, YARN-6492.006.WIP.patch, 
> YARN-6492.007.WIP.patch, partition_metrics.txt
>
>
> We are interested in having queue metrics for all partitions. Right now each 
> queue has one QueueMetrics object which captures metrics either in default 
> partition or across all partitions. (After YARN-6467 it will be in default 
> partition)
> But having the partition metrics would be very useful.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to