Hadoop QA commented on YARN-2083:

{color:green}+1 overall{color}.  Here are the results of testing the latest 
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author 

    {color:green}+1 tests included{color}.  The patch appears to include 1 new 
or modified test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with 

    {color:green}+1 findbugs{color}.  The patch does not introduce any new 
Findbugs (version 1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in 

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: 
Console output: https://builds.apache.org/job/PreCommit-YARN-Build/4019//console

This message is automatically generated.

> In fair scheduler, Queue should not been assigned more containers when its 
> usedResource had reach the maxResource limit
> -----------------------------------------------------------------------------------------------------------------------
>                 Key: YARN-2083
>                 URL: https://issues.apache.org/jira/browse/YARN-2083
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: scheduler
>    Affects Versions: 2.3.0
>            Reporter: Yi Tian
>              Labels: assignContainer, fair, scheduler
>             Fix For: 2.4.1
>         Attachments: YARN-2083-1.patch, YARN-2083-2.patch, YARN-2083-3.patch, 
> YARN-2083.patch
> In fair scheduler, FSParentQueue and FSLeafQueue do an 
> assignContainerPreCheck to guaranty this queue is not over its limit.
> But the fitsIn function in Resource.java did not return false when the 
> usedResource equals the maxResource.
> I think we should create a new Function "fitsInWithoutEqual" instead of 
> "fitsIn" in this case.

This message was sent by Atlassian JIRA

Reply via email to