[ 
https://issues.apache.org/jira/browse/YARN-1708?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14042917#comment-14042917
 ] 

Vinod Kumar Vavilapalli commented on YARN-1708:
-----------------------------------------------

I discussed a bit about this with [~subru] and [~curino] offline. Here's what 
we found in addition to the above comments that I had
 - It seems like ResourceRequest is getting overloaded with a bunch of things 
like concurrency and leaseDuration that today don't make sense when AM 
explicitly asks for containers. Similarly, priority today even after the 
reservation patches won't have much significance when submitting reservations. 
I propose we fork them so the ResourceRequest stays where it is today and then 
we have a new entity called ReservationResourceRequest. Long term, they may 
converge a little if not completely. 
 - ReservationDefinition.setResources() and getType() are really linked 
together. We should try to collapse them into a single method/API.
 - May be even rename ReservationDefinitionType to say something like 
ResourceRequest{Structure|Interpretation} or something of that sort.

> Add a public API to reserve resources (part of YARN-1051)
> ---------------------------------------------------------
>
>                 Key: YARN-1708
>                 URL: https://issues.apache.org/jira/browse/YARN-1708
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Carlo Curino
>            Assignee: Subramaniam Venkatraman Krishnan
>         Attachments: YARN-1708.patch
>
>
> This JIRA tracks the definition of a new public API for YARN, which allows 
> users to reserve resources (think of time-bounded queues). This is part of 
> the admission control enhancement proposed in YARN-1051.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to