[ 
https://issues.apache.org/jira/browse/YARN-2200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14045324#comment-14045324
 ] 

Karthik Kambatla commented on YARN-2200:
----------------------------------------

Is the plan to add a separate start time? Otherwise, it seems like a lot of 
work for no good reason. 

> Rename related container start time to container creation time
> --------------------------------------------------------------
>
>                 Key: YARN-2200
>                 URL: https://issues.apache.org/jira/browse/YARN-2200
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Jian He
>            Assignee: Jian He
>
> Creation time seems more appropriate than start time because it is the time 
> when the container created. start time is more like the time when container 
> is launched on NM.
> ContainerHistoryData.startTime, its getters and setters, ContainerStartData, 
> ApplicationHistoryWriter.containerStarted(), 
> WritingHistoryEventType.CONTAINER_START, WritingContainerStartEvent should 
> all be renamed. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to