[ 
https://issues.apache.org/jira/browse/YARN-659?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14094958#comment-14094958
 ] 

Tsuyoshi OZAWA commented on YARN-659:
-------------------------------------

[~jianhe] [~kkambatl] could you take a look, please? One design concern is that 
this change increases load against ZKRMStateStore when {{removeApplication}} is 
called.

> RMStateStore's removeApplication APIs should just take an applicationId
> -----------------------------------------------------------------------
>
>                 Key: YARN-659
>                 URL: https://issues.apache.org/jira/browse/YARN-659
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Tsuyoshi OZAWA
>         Attachments: YARN-659.1.patch, YARN-659.2.patch, YARN-659.3.patch, 
> YARN-659.4.patch, YARN-659.5.patch
>
>
> There is no need to give in the whole state for removal - just an ID should 
> be enough when an app finishes.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to