[ 
https://issues.apache.org/jira/browse/YARN-2404?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14116253#comment-14116253
 ] 

Jian He commented on YARN-2404:
-------------------------------

Tsuyoshi, thanks for your effort on this ! 
Skim through the patch. I think if we rename the ApplicationAttemptStateData to 
ApplicationAttemptState and ApplicationStateData to ApplicationState, that'll 
make the patch much smaller.

> Remove ApplicationAttemptState and ApplicationState class in RMStateStore 
> class 
> --------------------------------------------------------------------------------
>
>                 Key: YARN-2404
>                 URL: https://issues.apache.org/jira/browse/YARN-2404
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Jian He
>            Assignee: Tsuyoshi OZAWA
>         Attachments: YARN-2404.1.patch
>
>
> We can remove ApplicationState and ApplicationAttemptState class in 
> RMStateStore, given that we already have ApplicationStateData and 
> ApplicationAttemptStateData records. we may just replace ApplicationState 
> with ApplicationStateData, similarly for ApplicationAttemptState.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to