Tsuyoshi OZAWA commented on YARN-2515:

Thanks for your review, Jian. Updated to add ContainerId#fromString based on a 
following design:

* I moved the contents of ConverterUtils#toContainerId into 
ContainerId#fromString because ConverterUtils is in hadoop-yarn-common and 
hadoop-yarn-api doesn't depend on hadoop-yarn-common.
* A helper method, ConverterUtils#toApplicationAttemptId, is useful for 
implementing ContainerId#fromString, so the method is copied as 

> Update ConverterUtils#toContainerId to parse epoch
> --------------------------------------------------
>                 Key: YARN-2515
>                 URL: https://issues.apache.org/jira/browse/YARN-2515
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>         Attachments: YARN-2515.1.patch, YARN-2515.2.patch
> ContaienrId#toString was updated on YARN-2182. We should also update 
> ConverterUtils#toContainerId to parse epoch.

This message was sent by Atlassian JIRA

Reply via email to