[ 
https://issues.apache.org/jira/browse/YARN-2586?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Remus Rusanu resolved YARN-2586.
--------------------------------
    Resolution: Implemented

The next patch of YARN-2198 will contain this fix.

> Windows Secure Container Executor: use elevated file system operations to 
> cleanup the containers
> ------------------------------------------------------------------------------------------------
>
>                 Key: YARN-2586
>                 URL: https://issues.apache.org/jira/browse/YARN-2586
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>            Reporter: Remus Rusanu
>            Assignee: Remus Rusanu
>              Labels: security, windows
>         Attachments: YARN-2586.1.patch
>
>
> WSCE needs to use elevated filesystem operations (hadoopwinutilsvc backed) to 
> cleanup the container dirs. The NM does not have enough privileges to delete 
> these dirs. Similar to how LCE does it, using the root container-executor.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to