Tsuyoshi OZAWA commented on YARN-2562:

Thanks for the comments and suggestion, Jian and Vinod.

[~jianhe] OK, I'll add the comment in a next patch.

my fourth preference is to have something like 
container_1410901177871_0001_01_000005_e17, the first three preferences are 
what I proposed above 
[~vinodkv] I agree with changing the verbose prefix to "e". I think 
{{container_1410901177871_0001_01_000005_e17}} looks best way - it's human 
readable, easy to implement, and can be parsed with old ConverterUtil. I'll 
update a patch based on the approach.

> ContainerId@toString() is unreadable for epoch >0 after YARN-2182
> -----------------------------------------------------------------
>                 Key: YARN-2562
>                 URL: https://issues.apache.org/jira/browse/YARN-2562
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Tsuyoshi OZAWA
>            Priority: Critical
>         Attachments: YARN-2562.1.patch
> ContainerID string format is unreadable for RMs that restarted at least once 
> (epoch > 0) after YARN-2182. For e.g, 
> container_1410901177871_0001_01_000005_17.

This message was sent by Atlassian JIRA

Reply via email to