[ 
https://issues.apache.org/jira/browse/YARN-2562?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14158273#comment-14158273
 ] 

Hudson commented on YARN-2562:
------------------------------

FAILURE: Integrated in Hadoop-trunk-Commit #6185 (See 
[https://builds.apache.org/job/Hadoop-trunk-Commit/6185/])
YARN-2562. Changed ContainerId#toString() to be more readable. Contributed by 
Tsuyoshi OZAWA (jianhe: rev eb6ce5e97c6a379caf9de0b34cc7770c4447bb1a)
* hadoop-yarn-project/CHANGES.txt
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-api/src/main/java/org/apache/hadoop/yarn/api/records/ContainerId.java
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/test/java/org/apache/hadoop/yarn/api/TestContainerId.java
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/test/java/org/apache/hadoop/yarn/util/TestConverterUtils.java


> ContainerId@toString() is unreadable for epoch >0 after YARN-2182
> -----------------------------------------------------------------
>
>                 Key: YARN-2562
>                 URL: https://issues.apache.org/jira/browse/YARN-2562
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Tsuyoshi OZAWA
>            Priority: Critical
>             Fix For: 2.6.0
>
>         Attachments: YARN-2562.1.patch, YARN-2562.2.patch, YARN-2562.3.patch, 
> YARN-2562.4.patch, YARN-2562.5-2.patch, YARN-2562.5-4.patch, YARN-2562.5.patch
>
>
> ContainerID string format is unreadable for RMs that restarted at least once 
> (epoch > 0) after YARN-2182. For e.g, 
> container_1410901177871_0001_01_000005_17.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to