[ 
https://issues.apache.org/jira/browse/YARN-2722?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14181560#comment-14181560
 ] 

Stephen Chu commented on YARN-2722:
-----------------------------------

Hi [~ywskycn], thanks for making this change. Java 6 doesn't support TLSv1.2. 
Robert noted this in HADOOP-11217 as well. Should we be adding TLSv1.2 in this 
patch? 

> Disable SSLv3 (POODLEbleed vulnerability) in YARN shuffle
> ---------------------------------------------------------
>
>                 Key: YARN-2722
>                 URL: https://issues.apache.org/jira/browse/YARN-2722
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Wei Yan
>            Assignee: Wei Yan
>         Attachments: YARN-2722-1.patch
>
>
> We should disable SSLv3 in HttpFS to protect against the POODLEbleed 
> vulnerability.
> See [CVE-2014-3566 
> |http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3566]
> We have {{context = SSLContext.getInstance("TLS");}} in SSLFactory, but when 
> I checked, I could still connect with SSLv3.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to