[ 
https://issues.apache.org/jira/browse/YARN-2505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14195371#comment-14195371
 ] 

Wangda Tan commented on YARN-2505:
----------------------------------

1) NodeToLabelsInfo should be NodeIdToLabelsInfo, since we should be able to 
specify nodeId in REST API to consistent with YarnClient APIs and RM admin CLI.
2) Also we need change name of NodeToLabelsInfo#getNodeToLabels to 
getNodeIdToLabels if you agree with #1
3) I would prefer drop REST APIs to modifcation single nodeId or nodeLabels 
like 
{code}
+  @DELETE
+  @Path("/node-labels/{nodeLabel}")
{code}
Also like: addLabelsToNode/removeLabelsFromNode, etc.
Since we have 
{code}
+  @POST
+  @Path("/node-labels/remove")
{code}
Already.
The reason are: single/batch operations seems a little duplicated to me, set a 
map of nodeId -> labels is not a big burden to end user, regarding both API 
complexity and performance.

However, we can keep get APIs for labels on a node:
{code}
+  @GET
+  @Path("/nodes/{nodeId}/labels")
{code}
Since it may not always needed to return all node-to-labels mappings regarding 
performance. 

> Support get/add/remove/change labels in RM REST API
> ---------------------------------------------------
>
>                 Key: YARN-2505
>                 URL: https://issues.apache.org/jira/browse/YARN-2505
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Wangda Tan
>            Assignee: Craig Welch
>         Attachments: YARN-2505.1.patch, YARN-2505.11.patch, 
> YARN-2505.12.patch, YARN-2505.13.patch, YARN-2505.14.patch, 
> YARN-2505.3.patch, YARN-2505.4.patch, YARN-2505.5.patch, YARN-2505.6.patch, 
> YARN-2505.7.patch, YARN-2505.8.patch, YARN-2505.9.patch, YARN-2505.9.patch, 
> YARN-2505.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to