Karthik Kambatla commented on YARN-2236:

Sorry for the delay on this, Sangjin. Patch looks generally good, but for some 
minor comments: 
# LocalResource - mark the methods Public-Unstable for now, we can mark them 
Public-Stable once the feature is complete.
# Unrelated to this patch, can me mark BuilderUtils @Private for clarity. 
# Also, mark FSDownload#isPublic @Private
# Rename ContainerImpl#storeSharedCacheUploadPolicies to 
storeSharedCacheUploadPolicy? Also, should use block comments instead of line 
# LocalResourceRequest - LOG is unused, we should probably get rid of it along 
with its imports.
# SharedCacheChecksumFactory
## In the map, can we use Class instead of String? 
## getCheckSum should use conf.getClass for getting the classname, and 
ReflectionUtils.newInstance for instantiation to go with rest of the YARN code. 
Refer to RMProxy for further information. 
# Nit: SharedCacheUploader#call - remove the TODOs
# Instead of creating an event and submitting through the event-handler, would 
it be simpler to synchronously submit it since we are queueing it up to the 
executor anyway? 

> Shared Cache uploader service on the Node Manager
> -------------------------------------------------
>                 Key: YARN-2236
>                 URL: https://issues.apache.org/jira/browse/YARN-2236
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Chris Trezzo
>            Assignee: Chris Trezzo
>         Attachments: YARN-2236-trunk-v1.patch, YARN-2236-trunk-v2.patch, 
> YARN-2236-trunk-v3.patch, YARN-2236-trunk-v4.patch, YARN-2236-trunk-v5.patch
> Implement the shared cache uploader service on the node manager.

This message was sent by Atlassian JIRA

Reply via email to