Wangda Tan commented on YARN-3016:

I meant CommonNodeLabelsManager, methods start with "internal", we should have 
a way to make them easier.

> (Refactoring) Merge internalAdd/Remove/ReplaceLabels to one method in 
> CommonNodeLabelsManager
> ---------------------------------------------------------------------------------------------
>                 Key: YARN-3016
>                 URL: https://issues.apache.org/jira/browse/YARN-3016
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api, client, resourcemanager
>            Reporter: Wangda Tan
>            Assignee: Wangda Tan
> Now we have separated but similar implementations for add/remove/replace 
> labels on node in CommonNodeLabelsManager, we should merge it to a single one 
> for easier modify them and better readability.

This message was sent by Atlassian JIRA

Reply via email to