[ 
https://issues.apache.org/jira/browse/YARN-2984?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14269944#comment-14269944
 ] 

Anubhav Dhoot commented on YARN-2984:
-------------------------------------

Seems good. I tested it and shows up on the jmx page with its information
I would rename the ContainerUsageMetrics to just ContainerMetrics as I am 
thinking its a good place for all container related metrics instead of having 
multiple ContainerMetrics.


> Metrics for container's actual memory usage
> -------------------------------------------
>
>                 Key: YARN-2984
>                 URL: https://issues.apache.org/jira/browse/YARN-2984
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>    Affects Versions: 2.6.0
>            Reporter: Karthik Kambatla
>            Assignee: Karthik Kambatla
>         Attachments: yarn-2984-prelim.patch
>
>
> It would be nice to capture resource usage per container, for a variety of 
> reasons. This JIRA is to track memory usage. 
> YARN-2965 tracks the resource usage on the node, and the two implementations 
> should reuse code as much as possible. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to