[ 
https://issues.apache.org/jira/browse/YARN-2815?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14281019#comment-14281019
 ] 

Karthik Kambatla commented on YARN-2815:
----------------------------------------

I would hold off on upgrading to 3.5 at least until the ZK community calls the 
release GA. 

https://issues.apache.org/jira/issues/?jql=project%20%3D%20ZOOKEEPER%20AND%20affectedVersion%20in%20(3.5.0%2C%203.5.1)
 shows a bunch of issues with 3.5.

> Remove jline from hadoop-yarn-server-common
> -------------------------------------------
>
>                 Key: YARN-2815
>                 URL: https://issues.apache.org/jira/browse/YARN-2815
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Ferdinand Xu
>            Assignee: Ferdinand Xu
>         Attachments: YARN-2815.patch
>
>
> hadoop-yarn-server-common bundles ancient jline-0.9.94 as transitive 
> dependency of zookeeper-3.4.6 (it is used in the ZK CLI and not in Hadoop). 
> Beeline is moving to JLine2 and have to exclude this jline dependency so that 
> the hadoop classpath can use their own version (there is a newer JLine 2.12 
> that contains history search etc.)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to