[ 
https://issues.apache.org/jira/browse/YARN-3028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14286936#comment-14286936
 ] 

Rohith commented on YARN-3028:
------------------------------

Thanks [~leftnoteasy] for looking into patch.
bq. I think we should support "," as well, otherwise this will be a 
incompatible change.
Yes I agree with you. The attached patch address for both i.e "," and "="

bq. I suggest to leave tests for "," and "=", 
It is addressed in attached patch.

bq. and add a small comment in both code and help message indicate that we 
suggest user using "=" instead of "," because it will be more clear.
In the attached patch, I have changed help message to use "=". But we also 
support "," for compatibility. 

> Better syntax for replace label CLI
> -----------------------------------
>
>                 Key: YARN-3028
>                 URL: https://issues.apache.org/jira/browse/YARN-3028
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api, client, resourcemanager
>            Reporter: Jian He
>            Assignee: Rohith
>         Attachments: 0001-YARN-3028.patch
>
>
> The command to replace label now is such:
> {code}
> yarn rmadmin -replaceLabelsOnNode [node1:port,label1,label2 
> node2:port,label1,label2]
> {code}
> Instead of {code} node1:port,label1,label2 {code} I think it's better to say 
> {code} node1:port=label1,label2 {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to